After connecting to the remote computer, I’m unable to see or control the remote desktop.
Problem
After connecting to the remote computer, I select Remote Desktop Control but can’t see or control the remote desktop. However the application shows a Remote Desktop Control has been started status.
Cause
This issue occurs when the remote computer can’t access one or more of FixMe.IT’s communication server(s). A full list of FixMe.IT’s communication servers is provided on https://fixme.it/Test
Such server connectivity issues occur outside the scope of FixMe.IT’s application and are attributed strictly to local factor(s) within the end-user's system or environment. FixMe.IT support can't enable this access for the end-user.
Solution
Access to FixMe.IT’s servers may be blocked, restricted, or unavailable at various potential levels such as the user’s Operating System, local network, internet service provider, or other.
A common solution is to reset Internet Explorer settings: Start Internet Explorer -> Internet Options -> Advanced -> Reset
If the above IE reset doesn’t help, consult with the network administrator to ensure that access is enabled to all FixMe.IT communication servers listed on https://fixme.it/Test
Affected Operating Systems
- Windows XP
- Windows Server 2003
- Windows Vista
- Windows Server 2008/R2
- Windows Server 2012/R2
- Windows 7
- Windows 8/8.1
- Windows 10
- Windows 11