I'm unable to pay using a credit card issued in India

Last updated on Nov 04, 2022

Problem

I'm unable to submit an order using a credit card issued by an Indian bank.

Cause

As of October 2021, the Reserve Bank of India (RBI) has introduced new regulations for processing recurring transactions. More details on the RBI regulations can be found in this support article. Due to these changes, recurring payments in India may experience higher failure rates.

Solution

Our billing partners (Bluesnap and FastSpring) are in the process of evaluating the changes needed to support the RBI’s new framework. In the meantime, we recommend submitting the order via PayPal on this page or contacting our sales team for corresponding payment instructions.