Kaspersky Antivirus has blocked the Remote Control action
Problem
You’re unable to perform FixMe.IT Remote Control actions on a remote computer protected by Kaspersky Antivirus.
Cause
This issue is caused by Kaspersky’s "self-defense" mechanism which blocks any remote control activity apart from Microsoft Remote Desktop whenever the Kaspersky Settings window is in focus on the remote machine.
Solution 1
Add FixMe.IT to Kaspersky's Exclusion List on the remote computer:
- Install the FixMe.IT Client Application.
- Open the Kaspersky Settings window.
- Choose the Options menu and proceed to the Threats and Exclusions section.
- In the Exclusions section, click the Settings button.
- Open the Trusted applications tab.
- Click the Add button and choose the Applications menu item.
- Select the FixMe.IT Client Core application ending with "..\TiClientCore.exe".
- Check all boxes in the Exclusions for application list.
- Click OK in all opened dialogs to apply the new settings.
Solution 2
Close the Kaspersky Settings window or set focus to another window on the remote computer.
Affected operating systems:
- Windows XP
- Windows Server 2003
- Windows Vista
- Windows Server 2008/R2
- Windows Server 2012/R2
- Windows 7
- Windows 8/8.1
- Windows 10
- Windows 11