Kaspersky Antivirus has blocked the Remote Control action

Last updated on Dec 09, 2021

Problem

You’re unable to perform FixMe.IT Remote Control actions on a remote computer protected by Kaspersky Antivirus.

Cause

This issue is caused by Kaspersky’s "self-defense" mechanism which blocks any remote control activity apart from Microsoft Remote Desktop whenever the Kaspersky Settings window is in focus on the remote machine.

Solution 1

Add FixMe.IT to Kaspersky's Exclusion List on the remote computer:

  1. Install the FixMe.IT Client Application.
  2. Open the Kaspersky Settings window.
  3. Choose the Options menu and proceed to the Threats and Exclusions section.
  4. In the Exclusions section, click the Settings button.
  5. Open the Trusted applications tab.
  6. Click the Add button and choose the Applications menu item.
  7. Select the FixMe.IT Client Core application ending with "..\TiClientCore.exe".
  8. Check all boxes in the Exclusions for application list.
  9. Click OK in all opened dialogs to apply the new settings.

Solution 2

Close the Kaspersky Settings window or set focus to another window on the remote computer.


Affected operating systems:

  • Windows XP
  • Windows Server 2003
  • Windows Vista
  • Windows Server 2008/R2
  • Windows Server 2012/R2
  • Windows 7
  • Windows 8/8.1
  • Windows 10
  • Windows 11