"Another version of this product is already installed" error

Last updated on Dec 09, 2021

Problem

You may receive the following error upon attempting to install the FixMe.IT Expert application: Another version of this product is already installed.

Cause

This issue is usually attributed to a corruption or inconsistency in the local database that Windows uses to keep track of installed software. 

Solution

Please follow these steps to resolve the issue: 

Use care when modifying the Windows Registry.
  1. Press Win+R to open the Run box.
  2. Type regedit and click Ok.
  3. Navigate to HKEY_CURRENT_USER\Software\Microsoft\Installer\Products\
  4. Click on each key (subfolders within the Products folder) until you find one that has Product Name set as FixMe.IT Expert in the right pane.
  5. Delete the selected key.
  6. Reboot the PC.
  7. Install the software with a fresh msi: https://fixme.it/TechinlineExpert.msi

After the installation is complete, you can uninstall the software from the Windows Control Panel.


Affected operating systems: 

  • Windows XP
  • Windows Server 2003
  • Windows Vista
  • Windows Server 2008/R2
  • Windows Server 2012/R2
  • Windows 7
  • Windows 8/8.1
  • Windows 10
  • Windows 11