TalkTalk has restricted access to FixMe.IT

Last updated on Dec 09, 2021

Problem

You or the remote user are receiving an access restriction from TalkTalk (ISP) when trying to open the FixMe.IT website or application.

Cause

TalkTalk (well-known UK ISP) blocks their customers' access to all remote support applications, including FixMe.IT. In 2017 TalkTalk were victims of a scam in which Teamviewer was used to steal their subscribers' data, and have since implemented a policy to block their subscribers' access to all remote desktop software. 

Solution

The user needs to contact TalkTalk's customer service team and request that the restriction on using remote desktop software is removed from their account. TalkTalk has indicated that users will be able to change this setting themselves via their TalkTalk online account (My Account) starting in 2018.


Affected Operating Systems

  • Windows XP
  • Windows Server 2003
  • Windows Vista
  • Windows Server 2008/R2
  • Windows Server 2012/R2
  • Windows 7
  • Windows 8/8.1
  • Windows 10
  • Windows 11